您的位置: 网站首页 > 技术仓库 > Linux技术 > 阅读文章

Linux CentOS7 下安装 TeamViewer 的方法及错误处理

  TeamViewer 在 Windows 下非常好用,用于远程连接特别方便!现在要在一台 Linux 服务器(CentOS7)下同样安装 TeamViewer,应该怎么操作?

  官网下载地址: https://www.teamviewer.com/en/download/linux/,选择linux,下载rpm包,直接安装:
yum install teamviewer.x86_64.rpm

出现一个error提示,关键词:libQt5WebKitWidgets.so,以下是错误原文:

Error: Package: teamviewer-13.0.6634-0.x86_64 (/teamviewer.x86_64)
  Requires: libQt5WebKitWidgets.so.5()(64bit) >= 5.5
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

解决方法

在这个网址下载qt5-qtwebkit的库:

https://centos.pkgs.org/7/epel-x86_64/qt5-qtwebkit-5.6.2-1.el7.x86_64.rpm.html

直接附上qt5-qtwebkit Binary package的下载连接吧:

http://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/q/qt5-qtwebkit-5.6.2-1.el7.x86_64.rpm

rpm安装qt5-qtwebkit
rpm -Uvh qt5-qtwebkit-5.6.2-1.el7.x86_64.rpm

又出现错误,提示Header V3 RSA/SHA256 Signature,以下是错误原文:
warning: qt5-qtwebkit-5.6.2-1.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 352c64e5: NOKEY

百度故障原因:这是由于yum安装了旧版本的GPG keys造成的,解决的方法就是在rpm 语句后面加上–force –nodeps:
–nodeps 就是安装时不检查依赖关系;
–force 就是强制安装;

重新安装qt5-qtwebkit,终于装好了。
rpm -Uvh qt5-qtwebkit-5.6.2-1.el7.x86_64.rpm –force –nodeps

再次安装TeamViewer:
yum install -y teamviewer.x86_64.rpm

搞定,问题解决!

    • 本文标签:无
    • 人气热度:1,050
    • 生产日期:2018年10月19日 - 10时23分17秒